In this post I will show a basic configuration of Cisco Nexus 1000v after deployment presented here. We have deployed two Nexus 1000v VSM machines. Let's configure it!
The following configuration is based on some requirements:
- L3 control via mgmt0 interface
- Five VLANs: 22 (system vlan, L3 capability), 150, 300, 450, 777
- Port-Profile with LACP configured to the upstream switches
vCenter connection:
config t
svs connection vCenter
protocol vmware-vim
remote ip address 172.17.150.50
vmware dvs datacenter-name Datacenter1
connect
Switchname and VLAN database configuration:
conf t
switchname Nexus-Datacenter1
vlan 22
name vlan_system_control
vlan 150
name PROD1
vlan 300
name PROD2
vlan 450
name PROD3
vlan777
name PROD4
Port-Profile configuration for Virtual Machines:
port-profile type vethernet PROD_150
vmware port-group
switchport mode access
switchport access vlan 150
vmware max-ports 512
no shutdown
state enabled
port-profile type vethernet PROD_300
vmware port-group
switchport mode access
switchport access vlan 300
vmware max-ports 512
no shutdown
state enabled
port-profile type vethernet PROD_450
vmware port-group
switchport mode access
switchport access vlan 450
vmware max-ports 512
no shutdown
state enabled
port-profile type vethernet PROD_777
vmware port-group
switchport mode access
switchport access vlan 777
vmware max-ports 512
no shutdown
state enabled
Port-Profile configuration with L3 Capability:
port-profile type vethernet Nexus_Control
switchport mode access
switchport access vlan 22
no shutdown
capability l3control
max-ports 20
system vlan 22
state enabled
vmware port-group
Port-Profile configuration to the upstream switches:
port-profile type ethernet PROD_UPLINK
switchport mode trunk
switchport trunk allowed vlan 22,150,300,450,777
switchport trunk native vlan 1
vmware port-group
state enabled
system vlan 22
no shutdown
channel-group auto mode on
LACP configuration:
feature lacp
lacp offload
The configuration shown above is a basic configuration. If you need more features just leave a comment.